0.00  View cart

Support WooCommerce Easy Booking [Resolved] add to cart button disabled

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #7603
    jk
    Participant

    After I have chosen both start and end date on the product page still woocommerce-error “Please choose two dates” appears and the add-to-cart-button is disabled.

    #7604
    Ashanna
    Plugin's author

    Hello,

    I need a link to your website. Thank you.

    The “Please choose two dates” issue usually happens with cache plugins. Easy Booking is not compatible with caching and you need to disable it on the product pages.

    But it can be something else.

    Regards,
    Natasha

    #7605
    jk
    Participant

    Hello, Natasha,

    thank you for your quick reply! The “Please choose two dates” only appears in Chrome, not in Firefox, but the button is disabled in both browsers; a cache plugin is not installed.

    The shop still runs as localhost – I hope you may be able to help nevertheless.

    Regards,
    Johannes

    #7606
    Ashanna
    Plugin's author

    But if the add to cart button is disabled, you shouldn’t be able to click it and therefore you shouldn’t see the “Please choose two dates” message? Or am I missing something? When do you get the message exactly?

    It’s hard to tell without accessing the website.

    Is there any error somewhere?

    • Check for JS errors: open your browser console (F12 on a PC) and go to the “console” tab and select dates. Tell me if you see anything.
    • Check for PHP error, make sure debugging mode is enabled in your wp-config.php file:
    define( 'WP_DEBUG', true );
    define( 'WP_DEBUG_LOG', true );

    Then select dates and check the debug.log file (in wp-content).

    #7607
    jk
    Participant

    Hello Natasha,

    I could’nt get the error-messages when I repeated to load the page  in chrome …

    At the console I got the message:

    Uncaught TypeError: e(…).fadeTo(…).block is not a function
    at Object.wceb.setPrice (wceb.min.js?ver=1.0:1)
    at Object.wceb.pickers.set (wceb.min.js?ver=1.0:1)
    at Object.set (wceb.min.js?ver=1.0:1)
    at Object.trigger (pickadate.min.js?ver=1.0:1)
    at pickadate.min.js?ver=1.0:1
    at Array.map (<anonymous>)
    at r (pickadate.min.js?ver=1.0:1)

    At Sources  …\js\wceb.min.js?ver=1.0  I found this:

    … e(“form.cart, form.bundle_form”).fadeTo(“400″,”0.6″).block({message:null,overlayCSS:{background:”transparent”,backgroundSize:”16px 16px”,opacity:.6}}), … up to the end  underlined in red.

    Does that help?

    Regards, Johannes

    #7608
    Ashanna
    Plugin's author

    Allright, that’s most probably an issue with your theme or with another plugin.

    Please check this: https://wordpress.org/support/topic/t-addclass-block-is-not-a-function/.

    Try to switch to another theme (like Storefront or Tweentynineteen) to see if it’s the theme. If it’s not, disable all your plugins (except WooCommerce and Easy Booking) and enable them on by one to see which one is conflicting.

    Then it’s an issue with a script somewhere, but I won’t be able to help further without accessing the website.

    #7610
    jk
    Participant

    Hello Natasha,

    the problem was bootstrap 4 enqueuing jquery-3.3.1.min.js in the child-theme. Since I do not need bootstrap on this site, everything’s ok now! Thank you for your quick support!

    Regards, Johannes

    #7611
    Ashanna
    Plugin's author

    Great 🙂

Viewing 8 posts - 1 through 8 (of 8 total)

The topic ‘[Resolved] add to cart button disabled’ is closed to new replies.

Want to know what's next with Easy Booking? Check the roadmap!